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OneApp Pro Forms 

Design User Guide 
Technical Documentation –Version 5.3 

This documentation provides information and instruction 

regarding forms design in OmniForm as it relates to OneApp 

Pro. This documentation also includes instructions for using 

OneApp Pro design elements—including an explanation of 

how each piece works together to pinpoint the data needed 

for providers on credentialing applications. 
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Chapter 1: Introduction to OmniForm and its Basic Features 

 

Section 1.1 – OmniForm Overview & Support Disclaimer 
 

OmniForm is used to scan any form to be populated by the OneApp Pro database. Once a form has been scanned 

using OmniForm, saved, and mapped to the OneApp Pro database, it can be populated with provider data. 

 

OmniForm is a 3rd party software application developed by Nuance Communications and used in conjunction with 

OneApp Pro. Sy.Med Development, Inc. does not distribute, license, nor sell OmniForm to its clients. The following 

instructions are intended to assist with using OmniForm specifically for use with OneApp Pro. Please consult the 

OmniForm manual for additional instructions and support. 

Section 1.2 – Forms: Scanning & Initial Configuration  
 

This section describes how users would scan in new forms and get OmniForm configured for form design. 

 

Opening OmniForm 

To open OmniForm, click Start > Programs > ScanSoft OmniForm 5.0 > OmniForm 5.0 

 

Scanning Forms 

1. Place the first page of a form in the scanner bed. If the scanner being used has an Automatic Document Feeder 

(ADF), then place the entire form in the ADF tray.  

2. Click File > Scan Form or click the Scan Form button  in the toolbar. 

3. Select the Scanner Source. (If scanner is not available, see Appendix Section C.1 for scanner setup Instructions.) 

4. Select Auto as the Orientation. When Auto is selected, OmniForm will interpret the orientation of the page and 

scan accordingly. The orientation may be changed to correct misinterpreted pages. 

5. Important: Uncheck Convert Form Image to Editable Text.  

6. Check Auto Form Straightening. 

7. Check Add Page(s) to Current Form only if scanning multi-page documents without using an ADF. This option is 

not necessary when scanning page 1. It can also be used for adding addendums to various applications. 

8. To scan the next page in the form, when not using an ADF, repeat the steps above. The setting should save 

automatically. 
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Saving Forms 

Once the form has been completely scanned, it is recommended that the form be saved. 

 

1. Click File > Save As and name the form appropriately. 

2. Save the form in a subfolder of the default OneApp forms folder along with other credentialing applications*  

*Note: If locating the OneApp Default Forms Location is a problem, see Appendix Section C.2 for details on how to find it. 

Reordering Pages 

There is a menu in OmniForm that allows users to reorder a form’s pages; this is especially helpful if a new page has 

been scanned and added after the initial scanning process. Click Edit > Reorder Pages to use this feature. 

  

Adjusting the View 

If unable to easily view the form on the computer screen, adjust the view using the following steps: 

 

1. Select View > Zoom. 

2. Choose one of the pre-set Zoom options or enter a custom percentage and then click OK. 

Note: The view can also be changed by adjusting the percentage from the Zoom dropdown  on the menu bar.  

Section 1.3 – OmniForm Toolbars 
 

This section describes each toolbar in OmniForm and explains the functions that are commonly used with OneApp 

Pro forms design. 

 

The Design Toolbar 

The Design toolbar contains most of the general OmniForm functions. Many of these functions are similar to those 

in other applications. From left to right this tool bar contains the following command icons: 

 

New, Open, Save | Scan Form, Form Assistant | Print, Print Preview, Spelling | Cut, Copy, Paste | 

Zoom | Highlight Fillable Fields | Object Appearance, Object Definition, Size & Position  

Calculation, Tools, Help 

 

 

 

Highlight Fillable Fields       – This command highlights all of the fillable fields in the form yellow.  

 

Calculation      – This button turns the Calculation toolbar on and off.  
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The Arrange Toolbar 

The Arrange toolbar contains tools to help align fields with other fields and objects in the form. Multiple fields 

and/or objects must be selected in the form to use these features. This toolbar will be disabled without two or more 

fields selected. Users can either click multiple fields while holding down the SHIFT key or use the mouse to draw a 

box around the fields they wish to select. From left to right, this toolbar has the following command icons:  Bring to 

Front, Send to Back | Align Left, Align Right, Center Horiz. | Align Top, Align Bottom, Center Vertically  

 

 

 

Example: The selected fields below can be aligned using the Align Bottom button.  

 

Before: 

 

After: 

 

 

The Proofing Toolbar 

This toolbar has many useful options; however, most of them will not be used on a regular basis for forms mapping. 

For this purpose we will only cover the Field Name command icon.  

 

 

 

Note: If users are interested in the other features on the proofing toolbar, they can refer to the OmniForm help menu for 

additional information.  

 

Field Name  – This button toggles the field names on and off. When this button is selected, green labels will 

appear next to each fillable field. This is convenient when mapping forms because the field name can quickly be 

changed to one of the OneApp Pro Design Elements.* Please note, users will not be able to select or move any fields 

in the form while this button is turned on. See below for an example: 

 
 

*More information about OneApp Pro Design Elements can be found in Chapter 2 of this documentation. 

 

The Font/Text Toolbar 

The Font/Text toolbar contains many of the typical options for changing font style, alignment and size. To use this 

toolbar, select one or more items in the form. This toolbar will be disabled without any fields selected. 
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The Drawing Toolbar – Design Element Types 

The drawing toolbar has a number of commands that prove useful in the form mapping process. This documentation 

only goes into detail with the command icons that will be used the most during form mapping. This toolbar, by 

default, appears on the far left side of the OmniForm interface.  

 

Cursor (Select Objects) – This is selected by default and refers to the Windows mouse arrow.  

 

Label, Line, Oval, Rectangle, Graphic – These next five field types do not apply to form design as it relates to 

OneApp Pro. 

  

Fill Text  – This field type is used for the majority of the fields being mapped in credentialing applications.  

 

Note: For additional Information about the form mapping process, please refer to chapter 2 of this documentation. 

 

Comb – This field type allows users to fill Comb fields that may appear on electronically scanable forms. 

These fields require one character per box. The number of boxes for the comb fields can be changed by right-

clicking on them and editing their Object Definition settings, specifically their Number of Elements attribute. 

The Design Element Format* for this field type have Comb or C at the end and deal mainly with formatted 

numbers (i.e. Phone Numbers, Dates, Zip Codes). 

  

             *Note: Detailed information about OneApp Pro Design Element Formats can be found in Appendix Section A.3. 

 

Check Box  – This fillable field type allows users to fill checkboxes as they relate to information in the 

form. The fill format can be changed by right-clicking and selecting Object Definition. In the Object Definition 

menu select the Filling tab and change the value under the Mark section.  

 

Circle Text  – This field type allows users to fill circles around text; this is useful, for example, in cases 

where questions that ask to circle yes or no to answer.  
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Section 1.4 – OmniForm Limitations 

This section describes limitations on various features in OmniForm (i.e. Field Name length limits). 

 

OmniForm Field Name Length Limit (50 Characters) 

OmniForm has a set length limitation on field names. It will not allow users to create field names longer than 50 

characters.  

Note: This limit is not reached with most OneApp design element combinations (Discussed in Chapter 2 and Appendix A). Prior 

to OneApp Pro 5.3, formats would make extraordinarily long OneApp design elements pass the limit by a few characters. If this 

is the case, try using a format with a shorter character length; again, this problem was mostly eliminated in OneApp Pro 5.3 

where some formats and subsections were shortened in the system.  

OmniForm Page Limit for Forms (100 Pages) 

OmniForm restricts the number of pages that a form can have. Any form requiring more than 100 pages, should be 

broken up into multiple forms. 

 

Unique Field Name Identifiers 

OmniForm requires that field names be unique. If the exact same field name is needed in other locations on the 

form, simply add a number at the end of the field name. For example, many forms require the provider’s full name 

at the top or bottom of each page. The example below shows this but refers to OneApp Pro design elements; these 

will be covered in more detail in Chapter 2 of this documentation: 
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Chapter 2: Mapping Forms in OmniForm 

Once all pages of the form have been scanned and the document has been saved, the form mapping process can 

begin. This section shows the different steps needed in order to perform the mapping process. This is not a step-by-

step tutorial but rather a reference guide to assist with form mapping. It is suggested that users undergo forms 

training for a more detailed and formal walkthrough. 

Section 2.1 – Managing and Placing OmniForm Design Fields 

The first step to mapping a form, for use with OneApp Pro, is to place fillable fields on the form; each text, checkbox, 

and circle field being pulled from OneApp should have a fillable field associated with it on the form. This section will 

discuss putting each type of fillable field into a credentialing application. 

 

Inserting Fields 

To insert a new field on the form click the icon associated with the field type that’s needed in the Drawing Toolbar. 

Next, position the Window’s mouse cursor where the new field should appear and left-click to insert the new field. 

Here is an excerpt from our training form containing a number of different field types. 

 

 
 

Moving or Resizing Fields 

The fields can be moved by selecting and dragging them to the desired location. They can be resized by using the 

black squares that appear around the field once it has been selected.  

 

Note: If the Field Name viewer in the Proofing toolbar is turned on, users will not be able to select, move, resize or in any 

way, edit the fields in the form except for their field name. 

 

Changing Field Names 

Once the field is placed into the form, it is often necessary to change the field names. Click the Field Name*  

button in the Proofing toolbar to turn on the field name labels. Simply click one of the green labels to highlight it, 

and then delete all of the text inside. Finally, paste or type the desired field name into the label.  

Note: If the Field Name viewer in the Proofing toolbar is turned on, users will not be able to select, move, resize or, in any 

way, edit the fields in the form except for their field name. 
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Section 2.2 – Introduction to OmniForm Fillable Field Types 

This section discusses the different fillable field types in OmniForm and how they are used to fill in answers for 

specific types of questions. 

 

Fill Text Fields 

Fill Text  fields are located on the Drawing Toolbar and are by far the most commonly used field type in form 

design, depending on the form. They are used for general alphanumeric data. Most fill in the blank questions will 

use this field type (i.e. Addresses, Names, Dates, etc…). For example, the screenshot below uses a Fill Text field for 

the Home Address.  

 
 

Comb Fields 

Comb  fields are used to accommodate fields that require one character per box instead of a Fill Text field. It can 

also be used to accommodate specific formatting of text as required by the form. Most formatting needs are 

covered by our built in formats but in some cases comb fields can be used instead. For example, the screenshot 

below shows the Home Phone number utilizing a comb field for the last 7 digits of the phone number, (A Fill text is 

used for the area code.) 

 
 

Checkbox Fields 

Checkbox  fields, also located in the Drawing Toolbar in OmniForm, are used to fill option type questions from 

OneApp (i.e. Gender, Marital Status, Yes/No, True/False, etc…). For example, the screenshot below uses checkboxes 

to select a provider’s gender. 

 
 

Circle Text Fields 

Circle Text  fields are also used to fill option type questions from OneApp (i.e. Gender, Marital Status, Yes/No, 

True/False, etc…). Depending on the format of the option type question in the form, one or the other is necessary. 

For example, the screenshot below uses Circle Text fields to indicate the provider’s Marital Status. 

 

 

  



OneApp Pro 5.3 Design Element & OmniForm User Guide   

Sy.Med Development Inc. support@symed.com   (888) Sy.Med-88  8 

 

Section 2.3 – Introduction to the Design Element Clipboard  

The OneApp Pro Design Element Clipboard should be the primary source for selecting design elements for the form 

mapping process. This tool in OneApp’s Tools menu and allows users to construct the design element they need 

through its selection process. The selected item is copied and can be pasted in the appropriate field name on forms 

in OmniForm. These design elements drill down into the data to pinpoint the information needed from OneApp to 

put into the field in a credentialing application for a given provider. 

Accessing the Design Element Clipboard 
 

In OneApp Pro select the Tools option from the Main Menu; then click Design Element Clipboard. 

 

Documentation Disclaimer: Using the Design Element Clipboard to Map Forms 

The remainder of this documentation assumes that users are using the Design Element Clipboard in OneApp Pro to 

select design elements. We are also going to assume that the Convert Form Image to Editable Text checkbox was 

unchecked when the form was scanned into OmniForm.  

Section 2.4 – Mapping OmniForm Fields with OneApp Pro Design Elements 

This section takes users step-by-step in mapping an OmniForm Field using the Design Element Clipboard to select 

the desired element. 

 

Selecting a Design Element with the Design Element Clipboard 

This section describes each part of a design element and how to select one for use in a form. For the purposes of this 

section, let’s use the, Loc_Primary_1_Address_CSZ, as an example. There are four parts to the Design Element 

Clipboard. Three of these parts require a selection in order to copy the design element. The fourth part, Format, is 

only required if it is applicable to the Design Element type that’s selected. The example below shows the selections 

needed for the Primary Office Address using the CSZ format. 

 
 

Once a selection is made, click the Copy Field* button on the bottom the Design Element Clipboard, to the right. 

 

 

*Clicking this button copies the desired design element into the Microsoft Windows clipboard; it works exactly like the Copy 

feature in Windows when trying to “Copy & Paste” something from one place to another. The next step is to map the form field 

with the OneApp design element.  
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Mapping the OmniForm Field in OmniForm 

After selecting the desired field from OneApp’s Design Element Clipboard, switch back over to OmniForm and click 

the Field Name  button in the Proofing toolbar to turn on the field name labels; Click the green label next to the 

field that is going to be used for this design element to highlight all of the text inside. Then paste the design element 

from the Design Element Clipboard over the existing text. (Pasting can be done by using the Ctrl+V key combination 

on the computer keyboard or by right-clicking the highlighted text and selecting Paste).  

 

Reminder: Clicking the Copy Field in the Design Element Clipboard copies that design element to the Windows Clipboard ready 

to paste into the field name for one of the OmniForm fields. After pasting the design element into the field, the only parts of the 

name that may need to be changed are the range number or adding a unique identifier at the end of the field name.  

 

Repeat this process of selecting a Design Element from the Design Element Clipboard and pasting it in the field 

names of their associated OmniForm Field. Once all of the design elements are in place, the form is mapped. Please 

check the appendices of this document for additional information regarding design elements and other useful 

information.  

Unique Field Name Identifiers 

OmniForm requires that field names be unique. If the exact same field name is needed in other locations on the 

form, simply add a number to the end of the OneApp Design Element to make this field name unique. Be sure to 

avoid using the same number twice. For example, many forms require the provider’s full name at the top or bottom 

of each page. The example below shows The OneApp Pro design element for a physician’s last name; it has the 

number 1 at the end because this design element has been used previously in the form.  

 

Adding Blank fields 

Once all of the fields are mapped, in the OmniForm document, that have an associated OneApp design element, 

some fields will be left over. There will likely be some fields on the form that won’t have a built-in OneApp Pro field 

and/or design element. For now, just place blank fields here as place-holders to manually fill in the data after each 

form completion. As the data in OneApp Pro is developed over-time, user-defined fields can be added to 

accommodate any fields in the forms that do not have a built-in OneApp Pro field. These user-defined fields can be 

created on many of the screens themselves or in the User Defined screen for providers, offices, and practices. If they 

are created on the screens themselves, a design element is automatically generated. User-defined fields created in 

the User Defined screens require design elements to be created through a manual process; see Appendix Section 

B.3 under the sub-heading, Adding User Defined Fields to The Design Element Clipboard for more details. 

 

Additionally, some data (Today’s Date, Checkboxes and Circle text values, Text values, etc…) can be programmed to 

automatically generate into the form field using the Calculation feature of OmniForm. For details on how to do this, 

see Appendix Section B.4 for details. These fields should have generic names, such as FillText1, CheckBox1, 

CircleText1, or Comb1 so they do not conflict with OneApp Pro design Elements. The numbers increment depending 

on how many times the fields are used. See below for an example of a generic Fill Text field: 
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Appendix A: Design Elements Listings 

This appendix provides a listing of many of the design element sections formats, and more that are delivered with 

OneApp Pro. 

Appendix Section A.1 – Design Element Parts 

This section describes each part of a design element. For the purposes of this section, let’s use the, 

Loc_Primary_1_Address_CSZ, as an example. 

 

There are five pieces to OneApp Pro Design Elements. The fifth piece, Format, is only required if it is applicable to 

the Design Element type that is selected; otherwise, without a format, the design element only has 4 pieces. See the 

explainations below for each design element piece and how they are used to pinpoint the exact information needed 

from OneApp. 

 

Section – The first column in the Design Element Clipboard. Sections refer to the general location in the program 

where the information is stored in OneApp—this usually refers to a specific OneApp screen or Database Table. A full 

listing of design element sections is provided in Appendix Sections A.2 of this documentation.  

 

In example used here, Loc is the section abbreviation for locations, which refers to the Office Locations screen in 

OneApp Pro. Sometimes sections will refer to more than one related screens, but is very rare.  

 

Subsection – The top of the third column in the Design Element Clipboard. Subsections refer to a specific selection 

of the selected data; they are designed to exclude records that are not relevant to the users’ specific needs.  

 

In our example, Primary is the subsection and refers to the Primary Office Location as indicated by the primary 

checkbox in the Office Locations screen. This will only look for offices with that Primary checkbox checked. This 

would exclude all offices except for the Primary Office Location from the data selection.  

 

Note: The All subsection is present for all sections and selects all of the records associated with that section/field combination. 

In this example, all may select the primary office but could also select another office that the selected provider is located in. 

 

Record Number – There is not a place for this in the Design Element Clipboard; this part of the design element 

defaults to 1 and can be manually configured when put into the field name label on the OmniForm Document. 

 

 In our example 1 refers to the first record from the results that are pulled for that design element. Incrementing this 

number would refer to subsequent records that may or may not be present in the results that are pulled for that 

design element. For some design elements, in the case of a Primary Office Location for example, only one result is 

pulled and incrementing this number would result in a blank record since the provider only has one result. 
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Field – The second, or center, column in the Design Element clipboard. This part refers to the field in OneApp Pro 

containing the data needed in the form. There is typically a design element field for every field in every screen in 

OneApp Pro; some exceptions may apply; that is, a small number of fields in OneApp Pro may not have design 

elements associated with them. 

 

In our example Address refers to the address for the (Primary) Office Location Address. Typically this is the last 

piece displayed in the design element; the only time there would be something after this part is if a Design Element 

Format is necessary.  

 

Note: If the same design element is used more than once in a form, a number may follow the design element to make the field 

name unique in OmniForm. See the Unique Field Name Identifiers heading in Section 2.5 of this documentation for more 

details. 

 

Format – This is the bottom of the third column in the Design Element Clipboard. This part of the design element 

allows formatting options for certain types of fields. It is only required for five types of fields, Address, Date, Phone 

Number, Option, TriOption. A full listing of design element Formats is provided in Appendix Section A.3 of this 

documentation.  
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Appendix Section A.2 –Design Element Sections 

This Appendix Section lists all of the Design Element Sections in OneApp Pro, their associated screen, and other 

related information for each screen.  

 

Default Provider Level Sections 

This is a list of Design Element sections associated with the Provider that come with OneApp Pro and are not 

associated with OneApp Pro Premium or Special Features. 

 

Screen/Section Name Section 

Board Certifications SP 

Checklist CL 

Claims & Complaints MPC 

Continuing Education CME 

Covering Providers RP 

DEA & CDS Registrations DEA 

Disciplinary Actions Sac 

Documents (Provider) DOC 

Education ED 

Emergency Contacts EMRG 

Exams EXAM 

Extender Employees EX 

Facilities Fac 

*Health Status Phy 

Investments & Interests OL 

Liability Insurance MLP 

Licenses & Registrations SL 

Locations (Office Locations) Loc 

Medicaid MI 

Military Service MExp 

Payers PAY 

Personal Demographics Phy 

Professional Affiliations PA 

Provider Attestation Questions PAT 

Publications & Presentations PUB 

References PRef 

Services SER 

Taxonomy TAX 

User Defined (Provider) USR 

Work History WH 

 

*Some screens may have their design elements located in with the design elements for another screen. This is sometimes the 

case when screens are small, contain very little data and can be tied to another screen with similar information.  
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Other Default Sections 

This section lists OneApp Pro design element sections that are associated with Offices, Practices, Facilities, and 

Facility Provider levels of the tree. This section only shows sections associated with screens that come with OneApp 

Pro and are not associated with OneApp Pro Premium or Special Features. 

 

Screen/Section Name Section 

Documents (Office) DOCO 

Documents (Practice) DOCP 

Documents (Facility Provider) DOCFP 

Statistics (Practice) PS 

Site Visits (Practice) SV 

Taxonomy Practice (Practice) TAXP 

User Defined (Office) OUSR 

User Defined (Practice) PUSR 

 

Special Feature Sections 

This section does not apply to all clients; this lists sections that may have been created for special features used by 

some of our clients. Some, or all, of these may not apply to most users. 

 

Screen/Section Name Section Associated Project 

ApplySmart Identification Numbers ASID Minnesota Credentialing Collaborative 

ApplySmart Licenses ASLIC Minnesota Credentialing Collaborative 

ApplySmart Work Gaps ASGAP Minnesota Credentialing Collaborative 
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Premium Module Sections 

These OneApp Pro Design Element Sections are associated with various premium features. The NotiPhy, OneApp 

Facility, NPDB, Verification, and Privileging modules require an additional fee. They may, or may not, have been 

purchased with the the initial purchase of OneApp Pro. Check in the About section of the OneApp’s Help menu for 

specific client licensing details. For more information about these and other premium modules, including 

purchasing, please contact our support department. 

 

Screen/Section Name Section Tree Level Module 

Alert Email Fields Alert N/A NotiPhy 

NPDB NPDB Provider NPDB 

Privileging PRV Facility/Provider Privileging 

Verification VER Provider Verification 

Entity Accreditation ENAC Entity (Practice, Office, Facility) OneApp Facility 

Entity Attestation Questions ENAT Entity (Practice, Office, Facility) OneApp Facility 

Entity Bed Count (Beds Bottom) ENBC Entity (Practice, Office, Facility) OneApp Facility 

Entity Beds (Beds Top Grid) ENBD Entity (Practice, Office, Facility) OneApp Facility 

Entity Billing ENBL Entity (Practice, Office, Facility) OneApp Facility 

Entity Contacts ENCT Entity (Practice, Office, Facility) OneApp Facility 

Entity DEA Numbers ENDEA Entity (Practice, Office, Facility) OneApp Facility 

Entity Demographics ENDM Entity (Practice, Office, Facility) OneApp Facility 

Entity Details ENDT Entity (Practice, Office, Facility) OneApp Facility 

Entity Disciplinary Action ENDA Entity (Practice, Office, Facility) OneApp Facility 

Entity Equipment ENEQ Entity (Practice, Office, Facility) OneApp Facility 

Entity Fines ENFI Entity (Practice, Office, Facility) OneApp Facility 

Entity Investments ENIV Entity (Practice, Office, Facility) OneApp Facility 

Entity Laboratory Services ENLS Entity (Practice, Office, Facility) OneApp Facility 

Entity Lease ENLE Entity (Practice, Office, Facility) OneApp Facility 

Entity Liability Insurance ENLI Entity (Practice, Office, Facility) OneApp Facility 

Entity Licenses ENLC Entity (Practice, Office, Facility) OneApp Facility 

Entity Malpractice Claims ENMC Entity (Practice, Office, Facility) OneApp Facility 

Entity Medicaid ENMI Entity (Practice, Office, Facility) OneApp Facility 

Entity Officers ENOF Entity (Practice, Office, Facility) OneApp Facility 

Entity Offsite ENOS Entity (Practice, Office, Facility) OneApp Facility 

Entity Ownership ENOW Entity (Practice, Office, Facility) OneApp Facility 

Entity Payers ENPAY Entity (Practice, Office, Facility) OneApp Facility 

Entity Radiology Services ENRS Entity (Practice, Office, Facility) OneApp Facility 

Entity Service Providers ENSP Entity (Practice, Office, Facility) OneApp Facility 

Entity Services ENS Entity (Practice, Office, Facility) OneApp Facility 

Entity Test Individuals ENTI Entity (Practice, Office, Facility) OneApp Facility 

Entity Test Specialties ENTS Entity (Practice, Office, Facility) OneApp Facility 

Entity Test Volume ENTV Entity (Practice, Office, Facility) OneApp Facility 

Entity User Defined ENUSR Entity (Practice, Office, Facility) OneApp Facility 
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Appendix Section A.3: Design Element Formats with Examples 

 

Address – The Address formats allow OneApp to break addresses into different parts to fit the formatting 

requested by a form. The following Formats are associated with the address field type: 

Format Description Example 

City city New York 

CityState city and state New York, NY 

CSZ city, state, and zip New York, NY 12345-6789 

Full street, suite, city, state, zip 100 8th Ave. Apt C, New York, NY 12345-6789 

NameFull name, street, suite, city, state, zip ABC, Inc. 100 8th Ave. Apt C, New York, NY 12345 

State state NY 

Street street 100 8th Ave. 

StrSuite street and suite 100 8th Ave. Apt C 

Suite suite Apt C 

Zip zip 12345-6789 

ZipComb zip comb 1 2 3 4 5 6 7 8 9 

 

Attachment – This format is to facilitate document attachments on form. This corresponds to a feature in 5.3 

where documents can be generated and printed with enrollment application. 

Format Description Example 

Attach Document or Email Attachment N/A 

 

Date – The date formats allow OneApp to format or break up dates into different parts to fit the formatting 

requested by a form. The following formats are associated with the Date field type: 

Format Description Example 

DD 2-Digit Day 22 

MDY2C 2-Digit Month, Day, and Year Comb 1 0 2 2 9 5 

MDY4C 2-Digit Month, Day, 4-Digit Year Comb 1 0 2 2 1 9 9 5 

MM 2-Digit Month 10 

MMDDYY 2-Digit Month, Day, and Year 10/22/95 

MMYY 2-Digit Month and Year Oct-95 

MMYYYY 2-Digit Month, 4-Digit Year 10/1995 

MY2C 2-Digit Month and Year Comb 1 0 9 5 

MY4C 2-Digit Month, 4-Digit Year Comb 1 0 1 9 9 5 

Short Full Date (MM/DD/YYYY) 10/22/1995 

YY 2-Digit Year 95 

YYYY 4-Digit Year 1995 
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Option – The Option formats allow OneApp to format certain single checkboxes, yes/no, and other field types 

where two options are available that equate to Yes/No or True/False. These formats are used to format option type 

design elements different ways to meet the formatting requirements requested by the form. The following formats 

are associated with the Option field type: 

Format Description Example 

ChkN check if no X 

ChkY check if yes X 

CirN circle if no O 

CirY circle if yes O 

TF T if true, F if false T 

TrFa True if true, False if false TRUE 

YesNo Yes if yes, No if no Yes 

YN Y if yes, N if no Y 

 

Phone Number – The phone number formats allow OneApp to format phone numbers into different parts to fit the 

formatting requested by the form. The following formats are associated with the Phone Number field type: 

Format Description Example 

AC area code 888 

ACComb area code comb 8 8 8 

Local local (no area code) 796-3388 

LocalC local (no area code) comb 7 9 6 3 3 8 8 

Long area code + local 888-796-3388 

LongC area code + local comb 8 8 8 7 9 6 3 3 8 8 

Parens area code (in parentheses) + local (888) 796-3388 

 

State – This format was added in 5.3 and allows OneApp to apply different formats to the state design elements 

throughout the program. The following formats are associated with the State field type: 

Format Description Example 

StLng Non-Abbreviated State Tennessee 

StShort Abbreviated State (U.S. Postal) TN 

 

TriOption – The TriOption formats allow OneApp to format certain yes/no/Not-Applicable and other field types 

where three options are available that equate to Yes/No/Not-Applicable. These formats are used to format 

TriOption type design elements different ways to meet the formatting requirements requested by the form. The 

following formats are associated with the TriOption field type: 

Format Description Example 

TriCheckNA NA value X 

TriCheckNo No value X 

TriCheckYes Yes value X 

TriCircleNA NA value O 

TriCircleNo No value O 

TriCircleYes Yes value O 
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Appendix B: Advanced OmniForm Design Techniques. 

This chapter covers some advanced techniques that seasoned OneApp Pro and OmniForm users might find a need 

for. These techniques will not likely be needed for basic form design. 

Appendix Section B.1 – Pre-Filling Values for Fields 

OmniForm’s calculation function can also be used to display permanent values for fields that will have the exact 

same value every time the form is completed. Use generic names for these fields so that OneApp doesn’t try to 

overwrite them with information. First, turn on the Calculation field on by clicking Tools > Calculation. Then, click on 

the field that needs to pre-filled and click into the blank calculation field. Use the instructions below and continue 

for the field type being filled. 

 

Pre-Filling Text and Comb Fields 

Place the “desired text” in quotation marks and click the green check mark  in the calculation toolbar. 

    
 

Pre-Filling Circle-Text and Checkbox Fields 

Place the number 1 without any other text in the calculation field and click the green check mark  in the 

calculation toolbar. In the examples below, the circle text field for Female and the second checkbox had a calculated 

value of 1 which causes them to be circled or checked respectively every time a form is filled from OneApp.  

      

 

Displaying the Current Date on a Form 

OmniForm’s calculation function can also be used to display the current date in the field. First, turn on the 

Calculation field on by clicking Tools > Calculation. Then, click on the field where the date should be filled. In the 

calculation field, type Date()and click the green check mark  in the calculation toolbar. When form is completed, 

this field will display the current date. 

 

 

 

Appendix Section B.2 – Other Advanced OmniForm Techniques 

This section discusses advanced techniques that may be needed when designing forms in OmniForm. 

 

Design Element Validation 

OmniForm fields can be validated to make sure that the completed form isn’t printed with important fields that are 

blank but need to be filled. To require that a specific field be filled, right-click on the desired field and choose Object 

Definition; then select the Validation tab and check the checkbox next to Must be Filled in. Before the form can be 

closed or printed, OmniForm will display a warning if the validated field is empty. This can be done for as many fields 

as needed in a form, but OmniForm will generate a different validation message for each individual field that is 

blank. 
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Appendix Section B.3 – Advanced OneApp Techniques 

This section covers advanced techniques related to OneApp Pro that may be needed with form design. 

 

Adding User Defined Fields to the Design Element Clipboard 

Access the Design Element Editor in OneApp by clicking Configure > Design Elements. The following steps will guide 

users through accessing the information to use in forms design: 

 

1. Select the appropriate User Defined section from the section list on the left. See chart below for descriptions: 

Section Name Description Associated Table 

USR User Defined Section for Providers UserDefinedPhy 

OUSR User Defined Section For Offices UserDefinedOff 

PUSR User Defined Section For Practices UserDefinedPrac 

ENUSR User Defined Section For Entities (Practice, Office, Facility) UserDefinedEntity 

 

2. Click the User Defined Field Wizard button at the top in the Design Element Editor’s Action Toolbar. 

3.  Select the appropriate table (See chart Above) to add design elements from: 

 

A list of questions from the selected section will appear.  Be sure to only select the new records that need to be 

added to the Design Element Clipboard. Selecting a question that has already been added to the Design Element 

Clipboard will result in a duplicated field name. Once selections have been made, click OK. The design elements for 

the questions that were selected will now be available in the design element clipboard for use with Forms Mapping. 

 

Important Note: Before selecting any of these items in the checklist, verify that appropriate values are entered for 

the Design Element Name, in the User Defined Definitions screen, for the items needed. Do not enter a Design 

Element Name for Page Break and Line Break type User Defined Definitions. 
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Appendix C: OmniForm & OneApp Forms Completion Configuration 

Appendix Section C.1 – OmniForm Initial Configuration 

This section describes how to configure OmniForm for use with OneApp Pro forms. 

 

Turning Off “Tip of the Day” 

When OmniForm first loads, the Tip of the Day screen comes up. This is rarely helpful is often an annoyance when 

opening OmniForm since it will come up every time OmniForm is opened unless turned off. To turn this off, simply 

uncheck the box next to Show Tips on StartUp and click Close. 

 

 
 

Turning Off “Form Assistant” 

When OmniForm first loads, in addition to the Tip of the Day, the Form Assistant comes up. Again, this is rarely 

helpful especially when using OmniForm to manage forms for OneApp Pro. This will come up every time OmniForm 

is loaded unless it is turned off. To turn this feature off, uncheck the checkbox to the left of Show on StartUp and 

click Cancel. 

 

 
 

Setting up Scanners to Work With OmniForm 
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OmniForm 5.x is compatible with a variety of scanner types and brands. To check a scanner’s compatibility with 

OmniForm, go to http://support.nuance.com/compatibility/. In our experience, most TWAIN compatible scanners that 

are not listed in this list will probably work with OmniForm 5.x. 

 

OmniForm behaves differently with different scanners, drivers, and native scanning interface combinations. The 

OmniForm user’s manual or your IT staff for help configuring the scanner to work with OmniForm. To select a 

scanner, click File > Select Scanner. If the scanner is properly connected to the computer, the appropriate scanner 

TWAIN driver should come up. Go through the wizard to test and configure the scanner appropriately. 

 

Setting up Toolbars 

Most of the toolbars will be needed for the form design process. Use the following steps to enable the needed 

toolbars. 

 

1. With the Form Designer tab selected, click the View > Toolbars menu. 

2. Ensure that the following toolbars are checked:  
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Appendix Section C.2 – OneApp Pro Forms Configuration

This section describes any initial setup required in OneApp Pro in order to use the Forms Completion feature.

 

Organizing Forms into a Centralized 

OneApp Pro requires that all forms, being used with the Form Completion feature, be organized into one centralized 

location. Although there are many methods as to how those forms are organized in this location, there are a few 

basics that need to be covered. OneApp Pro has a feature that allows 

folder should contain only sub-folders; those sub

located directly in the directory that OneApp

below for example:  

 

 

Configuring the Default Forms Folder

To configure OneApp to point to a Default Form location, use the following steps:

1. Log into OneApp as an Administrative User.

2. Click Configure > Forms and then select the 

3. Select the folder that contains the
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OneApp Pro Forms Configuration 

This section describes any initial setup required in OneApp Pro in order to use the Forms Completion feature.

Organizing Forms into a Centralized Location 

OneApp Pro requires that all forms, being used with the Form Completion feature, be organized into one centralized 

location. Although there are many methods as to how those forms are organized in this location, there are a few 

be covered. OneApp Pro has a feature that allows users to point it to one starting folder, this 

folders; those sub-folders would contain the forms needed in OneApp. Forms or files 

located directly in the directory that OneApp points to will not be accessible in OneApp. See the sample structure 

  

 

Configuring the Default Forms Folder 

configure OneApp to point to a Default Form location, use the following steps: 

Log into OneApp as an Administrative User. 

and then select the Change Directory option from the Action Toolbar.

the form folders and click OK. 
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This section describes any initial setup required in OneApp Pro in order to use the Forms Completion feature. 

OneApp Pro requires that all forms, being used with the Form Completion feature, be organized into one centralized 

location. Although there are many methods as to how those forms are organized in this location, there are a few 

to point it to one starting folder, this 

folders would contain the forms needed in OneApp. Forms or files 

points to will not be accessible in OneApp. See the sample structure 

option from the Action Toolbar. 


